VM Junkie

February 25, 2009

VUM still not supported in VITK1.5

Filed under: Uncategorized — ermac318 @ 1:51 pm

Unfortunately, despite my excitement about the announcement of included PowerShell commands in VUM Update 4, there is nothing really new and it still is incompatible with the VI Toolkit version 1.5, as outlined here. I have emailed Carter asking when this will work with VITK 1.5, I will let you all know what he says.

In the meantime, if you’re willing to rollback to VITK 1.0 Update 1, it works great!

UPDATE: Carter responded via a comment on this entry!

Advertisements

2 Comments

  1. Since I got the same question at VMworld I wanted to mention that the incompatibility will be fixed when vSphere launches — there will be a new VI Toolkit and a new VUM snapin that will work together.

    Sorry for the inconvenience this is causing, this is probably not the only time this problem is going to occur. During major releases (pretend for a moment that they are 4.0, 5.0, etc) the cmdlets will work together, but we try to release the toolkit at a greater frequency than the platform and other similar incompatibilities may arise. Over time we hope to eliminate this, of course, but we may not have seen the last of this problem.

    Comment by Carter Shanklin — February 26, 2009 @ 8:24 am

  2. Carter,
    Thanks for the heads up! I’m honored to see you actually read my blog! =)
    Too bad that we have to wait for the next version for this, but I can understand that maintaining completely separate code bases can be challenging.
    Guess I’ll have to stick with the GUI for update manager in the meantime.

    Comment by ermac318 — February 26, 2009 @ 10:58 am


RSS feed for comments on this post.

Sorry, the comment form is closed at this time.

Blog at WordPress.com.

%d bloggers like this: